Demo & Step by Step Guide

Analyze & Visualize SQL
Server Data w/ PowerPivot,
PowerView & Excel

By: Wylie Blanchard - Great Tech Pros

Analyze & Present Data with PowerPivot &
Power View

Activate PowerPivot MS Excel add-in

Open MS Excel 2013

Go to File > Options > Add-Ins

In the Manage box, click COM Add-ins> Go

Check the Microsoft Office PowerPivot & Power View boxes
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COM Add-Ins

Add-Ins available:

[ Microsoft Power Map for Excel
Z‘ Power View
:‘Team Foundation Add-in

:‘ Inguire
:\2] Microsoft Office PowerPivot for Excel 2013

H ><

Cancel

Add...

Remove

!

Location:

Load Behavior: Load at Startup

C\Program Files\Microsoft Office 15\Root\Office15\ADDINS\PowerPivot Excel Add-in\PowerPivotExcelClientAddin.dll

PowerPivot tab

1. Click the PowerPivot tab

a. This is the tab where you work with PowerPivot PivotTables, calculated fields,
and key performance indicators (KPIs), and creating linked tables
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2. Click Manage to open the PowerPivot window
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Import Data from SQL Server

1. In the PowerPivot window, click Get External Data > From Database > From SQL
Server
2. In Connect to Microsoft SQL Server Database, in Server or File Name, enter the

name of SQL Server instance where your Data Warehouse is located.

3.  Click the down arrow to the right of the Database name list, and select an Analysis

Services database from the list
4.  Click Test Connection to verify that the server is available.
Click Next

Table Impaort Wizard

Connect to a Microsoft SQL Server Database

Enter the information required to connect to the Microsoft SQL Server database.

Friendly connection name: JSqIServer LAPTOP-P3AJK7V7 AdventureWorksDW2012

Server name:

Log on to the server

@ Use Windows Authentication

() Use SQL Server Authentication

User name: |

Password: |

Database name: |AdventureWorksDW2012

< Back Next >

Advanced

Einish

Test Connection

Cancel




6. Onthe Choose How to Import the Data screen click the radial button for Select from a
list of tables and views to choose the data to import
7.  Click Next
8.  Select the tables and views that you want included.
a. You can change any Source Table name to Friendly Name
b.  You can click Preview and Fllter to exclude columns and data
9.  Click Finish to complete import process

Table Import Wizard ? X
SeleciTables and Views

Select the tables and views that you want to import data from.

Server: LAPTOP-P3AJKIVY
Database: AdventureWorksDW2012

Tables and Views:

. Source Table Schema Friendly Name Filter Details Al
[ |IT AdventureWorksDWBuildVersion |dbo

[ ] | Databaselog dbo

[ ] | DimAccount dbo

[] DimCurrency dbo

= | DimCustomer dbo Customer

DimDate dbo Date

[ ]= | DimDepartmentGroup dbo

[ ] | DimEmployee dbo

= | DimGeography dbo Geography

[] DimOrganization dbo

@ | DimProduct dbo Product

DimProductCategory dbo Product Category

= | DimProductSubcategory dbo Product Subcategory

] DimPromotion dbo

["]l= | DimReseller dbo. L _ i

Select Related Tables | | Preview & Filter

< Back Next = Einish Cancel




Table Import Wizard ?
Imporiing
The import operation might take several minutes to complete. To stop the import operation, click the Stop Import button.
Q Total: 7 Cancelled: 0
Success
Success: 7 Emor: 0
Details:
| Work ltem Status Message
9 Customer Success. 18,484 rows transferred.
& Date Success. 2,191 rows transferred.
@ Geography Success. 655 rows transferred.
@ Product Success. 606 rows transferred.
@ Product Category Success. 4 rows transferred.
@ Product Subcategory Success. 37 rows transferred.
@ Internet Sales Success. 60,398 rows transferred.
@ Data preparation Completed Details
Stop Import Close

Completed Data Import (below)
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o Database = Service™ Sources Connections ¥ ¥
4 Get External Data
|[Custem... ~ £
B - - -
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12519 265 AWO00012519
12714 157 AW00012714
12728 131 AWO00012728
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14848 186 AWO00014848
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Display: lculated Fields Hierarchies KPls

[T DateKey

[ FullDateAlternatek...
[ DayNumberOfWeek
[ EnglishDayNameOf...

™ SnanishNavName ¥

= Internet Sales

[ ProductKey
[T OrderDateKey
F7 DueDateKey
[ ShipDateKey

7 ProductKey
T productAlternateKey
] ProductSubcategor...
7 WeightUnitMeasur...
1 CustomerKey 1 SizelInitMeasureC i
™ Geographykey

= Product Subcatego...

T Customerkev

] ProductSubcategor... &
1 ProductSubcategor...
1 EnglishProductSub...
F1 spanishProductSu...

= Customer

Create a PivotTable

1. While in PowerPivot click the PivotTable button

2.  Onthe Create PivotTable screen select New Worksheet
a. A new PivotTable Worksheet is created

3.  Under PivotTable Fields do the following
a. Go to Product. Select ModeIName
b.  Go to Internet Sales. Select OrderQuantity

4. Give it a title

5. Complete. You've created a PivotTable
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€10 fe | 328 v
B C G H . X

: PivotTable Fields ~ *
2 ACTIVE  ALL

3 Row Labels ~ Sum of OrderQuantity Choose fields to add to <
4 All-Purpose Bike Stand 249 report:

5 Bike Wash 908 weigne .
6 Classic Vest 562 DaysToManufacture

¥ (&

yeling Cap 20 Productline

8 Fender Set - Mountain 2121 7

9 Half-Finger Gloves 1430 dealerPrice

10 Hitch Rack - 4-Bike 328) Class

1 HL Mountain Tire 1396 D Style

12 HL Road Tire 858  ModeaNanie

13 Hydration Pack 733

14 LL Mountain Tire 862 Largebhoto -
15 LL Road Tire 1044 =

16 Long-Slesve Logo Jersey 1736 Drag fields between areas below:
17 ML Mountain Tire 1161 Y FILTERS Il coLumns
18 ML Road Tire 926

19 Mountain Bottle Cage 2025

20 Mountain Tire Tube 3095

21 Mountain-100 396

22 Mountain-200 3552 ROWS ¥ VALUES

23 Mountain-400-W 543 7

24 Mountain-500 479 ModelNa... ¥ Sum of Or... ¥
25 Patch kit 3191

26 Racing Socks 568

27 Road Bottle Cage 1712 =

i S};eetéﬁ 5Reét‘\ () T 4 3 Defer Layout Upda...

S

il W -+ 100%

Add a Hierarchy

In PowerPivot go to table/sheet Geography
Click the Diagram View button
a. Find the Geography table in the Diagram View
Right Click the table and then Select Create Hierarchy
Rename the “Hierarchy” to “Region Hierarchy”
Drag EnglishCountryRegionName to “Region Hierarchy”
Drag StateProvinceName to “Region Hierarchy” underneath EnglishCountryRegionName
Click the Data View button
Go back to your pivot table
Under PivotTable Fields do the following
a. Go to Geography. Select Region Hierarchy
b.  Region Hierarchy appears in the ROWS section.
10.  Drag Region Hierarchy from the ROWS section to the COLUMNS section
11.  Filter PivotTable to display only the United States
12.  Click the save button, name the workbook “SQLSatKC-PowerPivotExcelSQLAnalysis”
and close the workbook
13. Complete. You've created a Hierarchy and added it to your PivotTable
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HOME  INSERT  PAGE LAYOUT FORMULAS DATA REVIEW VIEW DEVELOPER POWERPIVOT  ANALYZE  DESIGN Wylie Blanchard ~
c6 - S || 354 v
A B C D E G H I J K ‘ .
T Grder Guanity e PivotTable Fields ~*
2 ACTIVE  ALL
3 Sum of OrderQuantity Column Labels ¥ Choose fields to add to g
4 Row Labels * = United States Grand Total report:
5 All-Purpose Bike Stand 85 85 b B
E .ustomer -
6 Bike Wash 354] 354
7 Classic Vest 229 229 v ER Date
8 Cycling Cap 680 680 4 [T Geography
9 Fender Set - Mountain 989 989 I || Region Hierarchy T
10 Half-Finger Gloves 538 538 b M :
[ More Fields
11 Hitch Rack - 4-Bike 141 141
—
12 HL Mountain Tire 662 662 I £ Internet Sales
13 HL Road Tire 343 343 b 2 Product
14 Hydration Pack 273 273 — s
15 LL Mountain Tire 301 301
16 LL Road Tire 286 286 Drag fields between areas below:
17 | Long-Sleeve Logo Jersey 697 697 Y FILTERS I coLuMNS
18 ML Mountain Tire 440 440 Region Hi
eqgion Hi. i}
19 ML Road Tire 234 234 :
20 Mountain Bottle Cage 827 827
21 Mountain Tire Tube 1329 1329
22 | Mountain-100 95 95 = ROWS ¥ VALUES
23 | Mountain-200 1261 1261
24 Mountain-400-W 212 212 Merielal, ~| | Sumaten, ™
25 Mountain-500 180 180
26 Patch kit 1165 1165
27 Racing Socks 237 237
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Adding a Calculated Column using DAX

Reopen the previously saved workbook “SQLSatKC-PowerPivotExcelSQLANalysis”
Go to the PowerPivot tab at the top of the Workbook
Click the Manage button
Go to a table (“InternetSales”)
Click a blank column click “Insert Column”
a. lIts default name is CalculatedColumn1. By right-clicking on the heading, the
following options are presented:

o bk owbd=



ﬂ STEEIC ~ || Calculate p
. 8/8/2007 12.. -
. 8/9/2007 12..
. 871172007 1..
.. 8/11/2007 1..
.. 8/12/2007 1..
- 8/14/2007 1..

52 Create Relationship..
2 Navigate to Related Table
Ba Copy
B Insert Column
=f Delete Columns
Rename Column
E

Freeze Columns
| Unfreeze All Columns
Hide from Client Tools
= Column Width...

Filter
nternet Sales.

Description...

3.  Select the “Rename Column” option and enter TotalProfit as the new column name
4.  Create a formula that will subtract the unit price (selling price) from the product cost
(cost to create/sell product) to arrive at the total profit.
a. DAX formula =[UnitPrice]-[ProductStandardCost]
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Diws o At °

T Paste Append ™y I L =t . [F™=]  DataTypetutoiturrenad = 31 Sort Smafiect to Largest W0F |
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| [TotalPro... 4 =|UnitPrice}-|ProductStandardCost] x
P productcost Bl salesamount B2 raxame Bl freight 3| Camerirackinghiumber B CustomersONumber [ Ordernata £ ousoste B3l shippats B3 TG 2
29.16 524.48 5195 S0.61 4/18/20081... 5/1/2008 .. 4/26/2008 ...
£9.16 524.49 5196 50,61 4/20/2008 1... 5/2/2008 ... 4/27/2008 ..
523.75 563.50 55,08 51.59 4/21/2008 1... 5/3/2008.. 4/28/2008...
£0.15 524.48 4106 50,61 4/21/20081.., 5/3/2008 .. 4/28/2008 ... i
523.75 563.50 $5.08 51.59 4/23(2008 1. 5/5/2008 ... 4/30/2008...
58,16 524.49 5196 50,61 4/25/2008 1... 5f7/2008 .. 5/2/20081... |
£23.75 563.50 55.08 51.59 4/26/2008 1., 5/8/2008 ... 5/3/20081...
420,57 554,99 54.40 5137 5/1/200812..; 5f13/2008.. 5/8/20081..
520,57 554.98 s4.40 51.37 5/1/2008 12.., 5/13/2008.. 5/8/20081...
544,88 $120.00 42,60 $3.00 5/3/2008 12... 5/15/2008... 5/10/2008 ...
544.88 5120.00 49,60 53,00 5/3/2008 12... 5/15/2008... 5/10/2008...
544,88 $120.00 $8.60 53.00 5/4/200812... 5/16/2008.. 5/11/2008 ...
52375 $63.50 55.08 51.59 5/5/2008 12... 5/17/2008., 5/12/2008...
i 544,88 $120.00 59,60 53,00 5/6/200812... 5/18/2008... 5/13/2008 ... |
58,16 524.45 51.96 50,61 5/7/200812.., 5/19/2008,, 5/14/2008...
s2.97 £7.95 50.64 50,20 5/7/2008 12... 5/19/2008... 5/14/2008.., |
544,88 $120.00 58,60 53.00 5/7/2008 12... 5/19/2D08.. 5/14/2008...
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5.  Complete, you've created a calculated column using DAX that indicates the total profit

Optional: Add two more Calculated Columns using DAX

1. Product Standard Cost < 25% of Unit Price
a. Create an additional column



b. Name the column “ProductStandardCost <40%”
c. Apply DAX formula =[ProductStandardCost]<(.40*[UnitPrice])
d. Your results should look similar to the image below
e. Complete. You've created a Calculated Column indicating whether the Product
Standard Cost is less than 40% of Unit Price
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$4.99 $0.40 $0.12 7/4/2008 12... 7/16/2008... 7/11/2008 ... 312
54.99 $0.40 $0.12 7/21/20081... 8/2/2008... 7/28/2008 ... :
Id 54.99 50,40 $0.12 7/22/20081... 8/3/2008 ... 7/29/2008 ...
54.89 50.40 s0:12 7/24/20081... 8/5/2008 ... 7/31/2008 ...
$4.99 $0.40 $0.12 7/26/20081.. 8/7/2008... 8/2/20081...
. $3,578.27 5286.26 589.46 7/2{200512... 7/14/2005... 7/9/20051...
[ sassezr sase2s 58945 7/14/20051... 7/26/2005... 7/21/2005 ...
[ sasre2r sas2s savds 7/15/2005 1., 7/27/2005... 7/22/2005..,
8 sas7827 328626 senae 7/17/20051... 7/29/2005... 7/24/2005 ...
|| sasrsar sws2e Ss9.4s 8/5/2005 12... 8/17/2005... 8/12/2005 ...
il $3578.27 528626 58946 8/7/200512... 8/19/2005... 8/14/2005...
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|| s3SI 28626 S0.46 8/18/2005 1... B/30/2005... 8/25/2005 ...
$3578.27  $286.26  589.46 8/19/2005 1... 8/31/2005... /26,2005 ...
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Record ® + 707 ot60.a88 0 on [=E3

2. Product Standard Cost % of Unit Price

a. Create an additional column Dt Ty At el Ny~
Name the column “ProductStandardCost % of UnitPrice” Format : Percentage ~
Apply DAX formula =[ProductStandardCost]/[UnitPrice] $-% > %%
Use the Apply Percentage Format button i
Use the Decrease Decimal button twice
Your results should look similar to the image below
Complete. You've created a Calculated Column displaying
difference between Product Standard Cost and Unit Price as
a percentage
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6/22/20081... 7/4/2008 .. 6/28/2008 ... 37%
smz 6/24/20081... 7/6/2008 ... 7/1/20081... %
s0.12 7/4/2008 12... 7/16/2008... 7/11/2008... 7%

$0.12 7/21/20081... /2/2008... 7/28/2008 ..
50.12 7/23f2008 1... Bf3/2008 .. 7/28/2008.. |
50.12 7/24/2008 1... 8(5/2008 ... 7/31/2008 ..,
$0.12 7/26/2008 1... 8/7/2008... §/2/20081...
58945 7/2/2005 12... 7/13/2005... 7/2/20081
520,46 7/14/2005 1.. 7/26/2005.. 7/21/2005... |
589.46 7/15/2005 1... 7/27/2005... 7/22/2005 ...
5849.46 7/17/2005 1... 7/29/2005... 7/24/2005.., |
$89.45 8/5/200512... 8/47/2005... B/12/2005 ...
589.45 . Bf7/200512... Bf19/2005.. Bf14/2005..)
589.45 8/10/2005 1.... 8/22/2005... B/17/2005 ...
589.46 B/18/20051... 8/30/2005... 8/25/2005...
- 589.46 (8/18/2005 1... §/31/2005.., 8/26/2005 ...
53046 9/5/2005 12... 9/17/2005... 9f12/2005...
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[ Custome | Date | Geogrenite | Broduct | st Coteory | Prashct subategors [intemet Sales | ) |
Record: 0« 701 of 60,306 o ¢ a-=
Addi M 5
ing a Measure -

20(

1. Select the first cell in the bottom grid section (aka the
“Calculation Area”) located just below the separation
line

| Customer |Date | Geography ‘ Product ‘ Produ
Record: W « 1 of 680,398 [

2. In the formula bar, located at the top of the worksheet,
a. type the following: “Sum of Total Profit:=SUM([TotalProfit])
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Paste _ From From Data From Other  Existing Refresh
E@ Copy Database ¥ Service™  Sources Connections >
Clipboard Get External Data

[Product... ~ fe ‘Sum of Total Profit:=SUM([TotalProfit])
 Productiey 1) [T O |
530 20080726 20080807

| 311 20050702 20050714



3. Right click the cell in the Calculation Area

4. From list, select Format
a. The Formatting window opens

5. Select the following in the Formatting window
a. Category = Currency

b. Symbol =§
c. Decimal places = 2
6. Click OK

7. Complete. You've created a Measure to sum the total profit

|| S 20050819 20050831 20050826 27918 E 100
] 311 20050905 20050 Formatting ? X
. 311 20050906 20050

] 314 20050906 20050, C3tE0o-

B 314 20050907 20050 |Sonorl il | Sl \L |
. 311 20050916 20050 V| Decimal places: 2 B

. 314 Cut Ctrl+X 51 Use 1000 separator (,)
M Copy Ctrl+C o1

. Sum of Total Profit: ... Pt Ctil+V T | oK | | Cancel
= Delete Del

. Create KPI...

- Hide from Client Tools

<

Format... ‘
| customer | Date | Geography | ubcategory |Internet Sales

Record: W + 1 of 60,398 Description...

Optional: Add another Measure

1. Click and Highlight the CustomerKey column
2. Then go to the AutoSum button and click the drop down symbol.
3. Select Distinct Count
4. Complete. You've created a Measure to count each unique customer key
| =
‘n“ E{:j Paste Append D r-1 D D D - Data Type: ™ f‘l SortAtoZ Y r M E AutoSum ~
3 u %I, Paste Replace fl @J .¢- e IJ Format: ~ ‘:]], SortZto A P( ‘LT Z Sum
Paste B From  From Data From Other  Existing Refresh  PivotTable 20 00 | A Clear All Sort by
“2) Copy Database ™ Service™ Sources Connections ¥ = $-% 2 7038 ZeClearsot Fjers Column~ Average
Clipboard Get External Data Formatting Sort and Filter Count
|[Product... > £ | Distinct Count
W roducier % Blorseroat.. % O buebst % B shipbat. % Bl Costomerkey I
> 311 20050805 20050817 20050812 Min
. 311 20050807 20050819 20050814 28014
. 311 20050810 20050822 20050817 28031
. 314 20050818 20050830 20050825 27681
. 311 20050819 20050831 20050826 27918
. 311 20050905 20050917 20050912 28182
. Sum of Total Profit: $12,080,883.65 Distinct Count of CustomerKey: 18484
[



Create a PowerPivot Workbook

1. Navigate back to your excel workbook to display your previously created PivotTable
2. Using the top Ribbon, go to Insert and then click the Power View button
3. Excel creates a Power View Sheet with your data model in the Field List

E W - Book1 - Excel
FILE HOME  INSERT ~ PAGE LAYOUT FORMULAS  DATA  REVIEW VIEW DEVELOPER  POWERVIEW  POWERPIVOT
x
ey
DOrag Helds hetw below
FILLDS
Sheet1 | Power View1 ® ] b

EE M -——+ 100%

4. In the Power View Fields list do the following
a. Go to Product. Select ModelName
b. Go to Internet Sales. Select OrderQuantity
5. Click where it says, “Click here to add a title” and type in “Order Quantities by Model
Name”.
6. Complete, you've created your another Power View report using your SSAS Tabular
Model



Filter the data in Power View using
Measure

1. In the Power View Fields Pane, Go to Product and find ModelName
2. Drag ModelName to the Filter pane
a. The table ModelName and its Columns will display under the Filter pane

Al

(Al

(Blank)

All-Purpose Bike Stand
Bike Wash

Cable Lock

Chain

Classic Vest

Cycling Cap

Fender Set - Mountain
Front Brakes

Front Derailleur
Full-Finger Gloves
Half-Finger Gloves
Headlights - Dual-Beam
Headlights - Weatherproof
Hitch Rack - 4-Bike

HL Bottom Bracket

HL Crankset

HL Fork

HL Headset

HL Mountain Frame

HL Mountain Front Wheel
HL Mountain Handlebars
HL Mountain Peda

3. Click on the Advanced Filter Mode button next FHEE
to ModelName in the Filter pane VIEW

4. In the text box under contains type “tire”

5. Click apply filter

6. The Power View table displays the order

quantities for tires only contains
7. Complete, you've applied a filter to your Power [tre
View table i

apply filter



Order Qua

ModelMame OrderQuantity 4
HL Road Tire 858
LL Mountain Tire 862
ML Road Tire 926
Touring Tire 035
LL Road Tire 1044
ML Mountain Tire 1161
HL Mountain Tire 1396
Touring Tire Tube 1488
Road Tire Tube 2376
Mountain Tire Tube 3095
Total 14141

Visualize your Data

1. Click the table

2. Go to the Design tab in the Ribbon

3. In the Switch Visualization section, click the Other Chart button and then click the “pie”
option
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Table Bar Column Other Map  Tiles Tile @ Slicer Ca
~  Chart~ Chart~ Chart~ Type Styl
Switch Visualization Tiles Slicer
Other Chart

Switch the visualization for this data
region to another type of chart.

|‘_—.Eu Power View

Tell me more

4. The table changes to a pie chart with a legend

Order Quantities by Model Name

B HL Mountain Tire
Bl HL Road Tire
LL Mountain Tire
% LL Road Tire
ML Mountain Tire
B ML Road Tire
Mountain Tire Tube
B Road Tire Tube
Touring Tire

Touring Tire Tube

5. Right click the chart and select the Copy option
6. Right click the chart and select the Paste button
a. A duplicate chart is created
7. Click on one of the charts and then using the top Ribbon:
a. select the Column Chart button in the Switch Visualization section
b. Select Stacked Column, which changes the visualization to a different chart type

Note: Interactivity: By clicking on any part of either chart, the visualization will interact and
react to your selection by highlighting/emphasizing your specific

Note: Interactivity: Direct your mouse/pointer to any portion of your chart - PowerView will
display additional data about that specific section

Note: Use the Filters pane to change data is displayed in your visualization what is displayed in
your charts

Note: You can change or add to the view by making additional selection from the Power View
Fields pane



8. Click the Save button
9. Complete, you've created a Power View visualization of your analyzed data

Order Quantities by Model Name

OrderQuantity by ModelName

ModelName
B HL Mountain Tire
Il HL Road Tire
B8 LL Mountain Tire
B LL Road Tire
0 ML Mountain Tire
B ML Road Tire

- Mountain Tire Tube
I Road Tire Tube
B Touring Tire
Touring Tire Tube

B
OrderQuantity by ModelName

HL Road LL Road ML Road Mountain Road Tire Touring Tire Touring Tire
Mountam Tire Mountam Tire Mountam Tire Tire Tube Tube Tube
Tire Tire Tire

3K

tl h jmanu::J

L — -

Optional: Power View Themes

8. Using the top Ribbon, click on the Power View tab  puiF LAYUU | FUKMULZ
9. Inthe Themes section there are several options

that allow you to further change your visualization A:Elj Font~

. Th ; ;
2 Foiges A 1Text Size ~
' . Themes
c. TextSize &) Background ~

d. Background
10. Utilize each option to further enhance your Power Themes
View Visualization



11. Using the top Ribbon, click on the Layout tab
12. In the Labels section there are several options that allow you to further change your
visualization

a. Title ——
b. Legend i IlimE
c. Data Labels o
d. Mao Background T'?e Legvend
13. Utilize each option to further enhance your Power il

View Visualization
14. Complete, you’ve further enhanced your Power
View report

END



BONUS MATERIAL



Use a Bl Semantic Model Connection
in Excel

Creating a Tabular Model Project

Open SQL Server Data Tools (Visual Studio)
Go to File > New > Project
Select project type Analysis Services Tabular Project
Insert the name of your Analysis Services Tabular instance
An empty model, Model.bim file is created
Go to Model > Import From Data Source
a. The Table Import Wizard window opens
7.  Select the Microsoft SQL Server option

ok wN =



Table Import Wizard ? et

Connect to a Data Source
You can either create a connection to a data source, or you can use one that
already exists.

Relational Databases ——M— ~

Microsoft SQL Server

Create a connection to a SQL Server database. Import tables or views from the database, or data
returned from a query.

i“@ Microsoft SQL Azure

Create a connection to a SQL Azure database. Import tables or views from the database, or data
returned from a query.

i’% Microsoft Analytics Platform System

Create a connection to a Microsoft Analytics Platform System. Import tables or views in the database,
or data returned from a query.

ﬁ Microsoft Access

Create a connection to a Microsoft Access database. Import tables or views from the database, or data
returned from a query.

@“@ Oracle

Create a connection to an Oracle database. Import tables or views from the database, or data
returned from a query.

@E Teradata

Create a connection to a Teradata database. Import tables or views from the database, or data
returned from a query.

By
Create a connection to a Svbase database. Import tables or views from the database. or data returned Y

< Back Next = Finish L Cancel

8. On the Connect to a Microsoft SQL Server Database screen, Insert the server name
of your Data Warehouse (SQL Server) instance and then select the name of the
database from the drop down box

9.  Click Next, and insert your connection on the prompting screens

10.  On the Select the Source Tables and Views screen place a checkmark next to each
tables and views that you want to include in your project
11.  Click Finish




Table Import Wizard ? X

Select Tables and Views
Select the tables and views that you want to import data from.

server: [N

Database: AdventureWorksDW2012

Tables and Views:

| ] Source Table Schema Friendly Name Filter Details ~
[ ]I | AdventureWorksDWBUildVers... | dbo

[ ]I= | DatabaselLog dbo

[ ]I= | DimAccount dbo

[ ]I | DimCurrency dbo

= | DimCustomer dbo Customer

B | DimDate dbo Date

[ ]I | DimDepartmentGroup dbo

[ 1= | DimEmployee dbo

£ | DimGeography dbo Geography

[ ]I= | DimOrganization dbo

= | DimProduct dbo Product

= | DimProductCategory dbo Product Category

£ | DimProductSubcategory dbo Product Subcategory

[ ]I | DimPromotion dbo w
—l_

‘ Select Related Tables ‘ ‘ Preview & Filter ‘

< Back ‘ Next = Finish ‘ Cancel ‘

12. Optionally, you can preview your data before moving




Table Import Wizard ? X
Preview Selected Table
Use the checkbox to select specific columns. To filter the data in a column, use the drop-down arrow for the column to select values that should be included.

Table Name: FactinternetSales

7] [ OrderDat... ~ B DueDat... ~ [ ShipDat... -~ B Custom... ~ [ Promotio... - [ Currenc... - [ SalesTerritor... - [ SalesOrderNu... ~ [ Sales A
il 310 20050701 20050713 20050708 21768 al 19 6 5043697

2 346 20050701 20050713 20050708 28389 1 39 7 5043698

3 346 20050701 20050713 20050708 25863 1 100 1 5043699

4 336 20050701 20050713 20050708 14501 1 100 4 5043700

5 346 20050701 20050713 20050708 11003 1 6 9 5043701

6 311 20050702 20050714 20050709 27645 1 100 4 5043702

7 310 20050702 20050714 20050709 16624 1 6 9 5043703

8 351 20050702 20050714 20050709 11005 1 6 9 5043704

9 344 20050702 20050714 20050709 11011 1 6 9 5043705

10 312 20050703 20050715 20050710 27621 1, 100 4 5043706
111 312 20050703 20050715 20050710 27616 1 100 4 5043707

12 330 20050703 20050715 20050710 20042 1 98 10 5043708

3 313 20050703 20050715 20050710 16351 1 6 9 5043709

14 314 20050703 20050715 20050710 16517 1 6 9 5043710

15 214 2005n704 INNSN71A 0NSN711 I76NA 1 1nn 1 eNa711

< > v
Clear Row Filters Cancel

Table Import Wizard

Importing

The import operation might take several minutes to complete. To stop the import
operation, click the Stop Import button.

‘o Total: 7 Cancelled: 0
Success
Success: 7 Error: 0
Details:
] Work Item Status Message
'@ Customer Success. 18,484 rows transferred.
.9 Date Success. 2,191 rows transferred.
@ Geography Success. 655 rows transferred.
@ Product Success. 606 rows transferred.
@ Product Category Success. 4 rows transferred.
@ Product Subcategory Success. 37 rows transferred.
@ Internet Sales Success. 60,398 rows transferred.
@ Data preparation Completed Details




13. Final view of the model (below) - note the tabs at the bottom of the screen

Debug Model Table Column  Team  Tools  Test  Analyze  Window  Help ‘Wylie Blanchard ~
- O [ B selectPerspective <Default> - P S| = Q| HF-E-Fu

- b st - | B

il rodelt bime = %

[Customer... =

=

| 4 Custom. " - Geograoh... i+ Customerliernatekey = [itle - Firsthame - MiddeName - Lasthame - NameStyle -

B-S¢aB| p -

oo

Tt 11602 135 AWO0011602 Larry Gill FALSE Search Solution Explorer (Chils ;) P
A 11603 244 AWLOD1 1603 Geoffrey L»'an_zalez FaLsE m Solution labularfrojects {1 project)
3 l_lGIﬂ 2_6? AWDODIIIGID Blake Collins FML§E G E}!Tahularl’mjam
‘f‘ 12517 133 AWDOD12517 Alexa Watson FALSE P
5 12518 161 AWOOD12518 Jarquelyn Dominguez FALSE R
& 12419 265 AWDOM 2519 Casey Gulierrez FALSE W Model1.bim
ir 12714 157 AW00012714 Calleen Lu FALSE
8 12778 131 AWDOO12728 leremizh Stewarl FALSE
9 12871 233 AWO0O0DL2571 Leah Li FALSE
10 13671 173 AWD0013671 Frank Rarmos FALSE
1 13826 127 AWO00135826 Candlce He FALSE
12 13830 237 AWDODI3R30 Anrlrea Cox il SE
13 13638 263 AWOO0013838 alll| Rubla FALSE
14 14R38 121 AWNOD14R2R Dirren Alvarez FilSE
15 14835 238 AWOO0L483% Matasha Sanz FALSE v ¥ .
& Pt r Atoniisin pi— = e S ML Team Explorer Class View
17 14848 186 AW00014848 George Louverdls FALSE
18/ 14849 147 AWNOM1 4849 Dviarymie Martin FALSE o
1 14091 272 AWOO014091 Edwin Zhao FALSE ::“"“"r Jakle
e 16317 263 AWDODTE31T Tael Raman FALSE =5 F
121 16452 232 AWOODLE452 Cassle Luo FALSE Formik =
122 16453 271 AWDOD16453 Mayra Chandra Fase v B idden False
Partitions {Click to edit)
Source Nata {Click 1o edit)
Table Description
lakle Mame Customer
| » Fl Rennrtina Pronarties b
: Customer,] Jatc,l Geography | Product l Product Category | Product Subcategory . Internet Sales Jan Table Name

Record: 1€ € 1 of 18,484 The narne of the table, as it is stored in the mocdel

Deploy the Tabular Model

1.

Right-click the project name
select Properties
a. Properties box opens
Ensure that the Server property displays the name of your Tabular instance
Click Ok
Go to Build > Deploy TabularProject 1 (the name of your project)
Your project is now deployed to the server

N

o0k w



Deploy ? X
Deploying

The deployment operation may take several minutes to complete.

o 8 Total 0 Cancelled
Success

8 Success 0 Error

Details:
Work Item Status Message
Deploy metadata Success. Metadata deployed.

@ Customer Success. 18,484 rows transferred.

‘Q Date Success. 2,191 rows transferred.

@ Geography Success. 655 rows transferred.

‘Q Product Success. 606 rows transferred.

@ Product Category Success. 4 rows transferred.

‘Q Product Subcategory Success. 37 rows transferred.

@ Internet Sales Success. 60,398 rows transferred.

SASS to Power View Quickly

Open MS Excel

Create a blank workbook

Go to Data > From Other Sources > Get External Data > From Analysis Services
In the Connect to Database Server screen, in Server Name, enter the name of SQL

PoODN=

Server Analysis instance where your Tabular Model was deployed.
Select your Tabular Model

Select Next, then click Finish



Data Connection Wizard ? *

Select Database and Table

Select the Database and Table/Cube which contains the data
YO want,

Select the database that contains the data you want:

TabularProject’_wylie_597b15c0-1982-4230-a7d0-aa792a750189d -~

|_7| Connect to a specific cube ar table:

Mame Description  Modified Created  Type

Yol | /12/2016 3:36:50 AM CUBF

< 7|
Cancel [ < Back | et > Einish

7. On the Import Data screen, select Power View Report
8.  Excel creates a Power View Sheet with your tabular data model in the Field List.

IR Book - Excel ?E - O %
HOME INSERT PAGELAYOUT FORMULAS DATA REVIEW VIEW DEVELOPER POWERVIEW  POWERPIVOT Wylie Blanchard'l',-gﬁi
Filters ¢ x Power View Fields x =
VIEA ALTVE ALL e |

1 B DivnC ustomer

b [T BimDate

& B DimGengraghy

& B Mirndroduict

I+ [T BimProdutCalegery

1 B i rodustSuheatageny

DOrag flelds hetween aress balaw:
FIELDE

Sheet! | Power View1 ® 1[4 | b

9. In the Power View Fields list do the following
a. Goto Product. Select ModeIName
b.  Go to Internet Sales. Select OrderQuantity
10.  Click where it says, “Click here to add a title” and type in “Order Quantities by Model
Name”.
11.  Click the save button, name the workbook “SQLSatKC_SSAStoPower View” and close



the workbook
12.  Complete, you've created your first Power View report using your SSAS Tabular Model

H S 2-34-- Book1 - Excel ?7 W - O %X
HOME  INSERT  PAGE LAYOUT FORMULAS DATA  REVIEW VIEW  DEVELOPER POWER VIEW  POWERPIVOT Wylie Blanchard ~ |
. Filters < x Power View Fields 3 el
Order Quantities by Model Name . s o ]
[]x Freight =
MogelName OrderQuantity [[] orderDate
All-Purpose Bike Stand 249 D 3 OrderDateKey
Bike Wash 908 []% Orderquantity
Classic Vest se2 C]E Producikey
Cyding Cag e [[]% ProductStandardCost
Fender Set - Mountain 2121
[[]% Promotionkey
Half-Finger Gioves 1430 E
Hitch Rack - 4-Bike 328 1% RevisionNumber
HL Mountain Tire 1396 [[]3 salesamount
HL Road Tire 858 ] SalesOrderlineNumber
Hydration Pack 733 [] salesOrderNumber =
LL Mountain Tire 862 :
LL Road Tire 1044 Drag fields between areas below:
Long-Sleeve Logo Jersey 1736 5
ML Mountain Tire 1161
ML Road Tire 926
-
| Sheet1 | Power Viewl | (® « ] »




